// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[-+]?(\d+(\.\d*)?|\.\d+)([eE][-+]?\d+)?").unwrap();
let string = "PLOAD4,105,5686,1.091300E+05,,,,,
PLOAD4,105,5686,-1.912900E+05,,,,,
8243965,81.8897
8243965,-18.2857
7,P,-101761
7,P,1671011
177842,P,-100588
177842,P,912598
*DLOAD
*TEMPERATURE";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}