import Foundation
let pattern = #"[-+]?(\d+(\.\d*)?|\.\d+)([eE][-+]?\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
PLOAD4,105,5686,1.091300E+05,,,,,
PLOAD4,105,5686,-1.912900E+05,,,,,
8243965,81.8897
8243965,-18.2857
7,P,-101761
7,P,1671011
177842,P,-100588
177842,P,912598
*DLOAD
*TEMPERATURE
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)