using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[-+]?(\d+(\.\d*)?|\.\d+)([eE][-+]?\d+)?";
string input = @"PLOAD4,105,5686,1.091300E+05,,,,,
PLOAD4,105,5686,-1.912900E+05,,,,,
8243965,81.8897
8243965,-18.2857
7,P,-101761
7,P,1671011
177842,P,-100588
177842,P,912598
*DLOAD
*TEMPERATURE";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}