use strict;
my $str = 'PLOAD4,105,5686,1.091300E+05,,,,,
PLOAD4,105,5686,-1.912900E+05,,,,,
8243965,81.8897
8243965,-18.2857
7,P,-101761
7,P,1671011
177842,P,-100588
177842,P,912598
*DLOAD
*TEMPERATURE';
my $regex = qr/[-+]?(\d+(\.\d*)?|\.\d+)([eE][-+]?\d+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}