import re
regex = re.compile(r"[-+]?(\d+(\.\d*)?|\.\d+)([eE][-+]?\d+)?", flags=re.MULTILINE)
test_str = ("PLOAD4,105,5686,1.091300E+05,,,,,\n"
"PLOAD4,105,5686,-1.912900E+05,,,,,\n\n"
"8243965,81.8897\n"
"8243965,-18.2857\n\n"
"7,P,-101761\n"
"7,P,1671011\n\n"
"177842,P,-100588\n"
"177842,P,912598\n\n"
"*DLOAD\n"
"*TEMPERATURE")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")