$re = '/[-+]?(\d+(\.\d*)?|\.\d+)([eE][-+]?\d+)?/m';
$str = 'PLOAD4,105,5686,1.091300E+05,,,,,
PLOAD4,105,5686,-1.912900E+05,,,,,
8243965,81.8897
8243965,-18.2857
7,P,-101761
7,P,1671011
177842,P,-100588
177842,P,912598
*DLOAD
*TEMPERATURE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);