# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/#[^\n#]*/*/gm;t' <<< "# heading 1
##
...
##### heading 5"