#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)#[^\n#]*"
Local $sString = "# heading 1" & @CRLF & _
"##" & @CRLF & _
"..." & @CRLF & _
"##### heading 5"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)