const regex = /#[^\n#]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#[^\\n#]*', 'gm')
const str = `# heading 1
##
...
##### heading 5`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);