re = /#[^\n#]*/m
str = '# heading 1
##
...
##### heading 5'
subst = '*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result