use strict;
my $str = '# heading 1
##
...
##### heading 5';
my $regex = qr/#[^\n#]*/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";