$re = '/#[^\n#]*/m';
$str = '# heading 1
##
...
##### heading 5';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;