import re
regex = re.compile(r"#[^\n#]*", flags=re.MULTILINE)
test_str = ("# heading 1\n"
"##\n"
"...\n"
"##### heading 5")
subst = "*"
result = regex.sub(subst, test_str)
if result:
print(result)