#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:in a|in the|in) ?(.+?) ?(?:area|section)"
Local $sString = "Then there should be 3 elements in the article list section" & @CRLF & _
"Then there should be 3 article preview elements in the article list section" & @CRLF & _
"Then there should be 3 article preview elements in the article list section in the article section"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")