re = /(?:in a|in the|in) ?(.+?) ?(?:area|section)/
str = 'Then there should be 3 elements in the article list section
Then there should be 3 article preview elements in the article list section
Then there should be 3 article preview elements in the article list section in the article section'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end