$re = '/(?:in a|in the|in) ?(.+?) ?(?:area|section)/';
$str = 'Then there should be 3 elements in the article list section
Then there should be 3 article preview elements in the article list section
Then there should be 3 article preview elements in the article list section in the article section';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);