import Foundation
let pattern = #"(?:in a|in the|in) ?(.+?) ?(?:area|section)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Then there should be 3 elements in the article list section
Then there should be 3 article preview elements in the article list section
Then there should be 3 article preview elements in the article list section in the article section
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)