const regex = /(?:in a|in the|in) ?(.+?) ?(?:area|section)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:in a|in the|in) ?(.+?) ?(?:area|section)', 'g')
const str = `Then there should be 3 elements in the article list section
Then there should be 3 article preview elements in the article list section
Then there should be 3 article preview elements in the article list section in the article section`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}