# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((.*)\s(\[.*\])(\s.*))/\3 \2\4/gm;t' <<< "name [artist] (magazine) {tags}
"