#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((.*)\s(\[.*\])(\s.*))"
Local $sString = "name [artist] (magazine) {tags}" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "\3 \2\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)