$re = '/((.*)\s(\[.*\])(\s.*))/m';
$str = 'name [artist] (magazine) {tags}
';
$subst = "\3 \2\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;