use strict;
my $str = 'name [artist] (magazine) {tags}
';
my $regex = qr/((.*)\s(\[.*\])(\s.*))/mp;
my $subst = '\\3 \\2\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";