using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((.*)\s(\[.*\])(\s.*))";
string substitution = @"\3 \2\4";
string input = @"name [artist] (magazine) {tags}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}