import Foundation
let pattern = #"((.*)\s(\[.*\])(\s.*))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
name [artist] (magazine) {tags}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\3 \2\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)