package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((.*)\s(\[.*\])(\s.*))`)
var str = `name [artist] (magazine) {tags}
`
var substitution = "\3 \2\4"
fmt.Println(re.ReplaceAllString(str, substitution))
}