# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\d)(\d)(?=,|$)/0\1/g;t' <<< "file8, file9, file10"