use strict;
my $str = 'file8, file9, file10';
my $regex = qr/(?<!\d)(\d)(?=,|$)/p;
my $subst = '0\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";