import Foundation
let pattern = #"(?<!\d)(\d)(?=,|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"file8, file9, file10"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)