using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\d)(\d)(?=,|$)";
string substitution = @"0\1";
string input = @"file8, file9, file10";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}