$re = '/(?<!\d)(\d)(?=,|$)/';
$str = 'file8, file9, file10';
$subst = "0\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;