const regex = new RegExp('(?<!\\d)(\\d)(?=,|$)', 'g')
const str = `file8, file9, file10`;
const subst = `0\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);