import re
regex = re.compile(r"(?<!\d)(\d)(?=,|$)")
test_str = "file8, file9, file10"
subst = "0\\1"
result = regex.sub(subst, test_str)
if result:
print(result)