#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[0-9]+(?:\.[0-9]+)+"
Local $sString = "get_a_string_A14_for_1.23.87.19_A12_and_others" & @CRLF & _
"get_a_string_A14_for_1.23.827.19_A12_and_others" & @CRLF & _
"get_a_string_A14_for_1.23.87.1_A12_and_others" & @CRLF & _
"get_a_string_A14_for_2.23.87.19_A12_and_others"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")