import re
regex = re.compile(r"[0-9]+(?:\.[0-9]+)+")
test_str = ("get_a_string_A14_for_1.23.87.19_A12_and_others\n"
"get_a_string_A14_for_1.23.827.19_A12_and_others\n"
"get_a_string_A14_for_1.23.87.1_A12_and_others\n"
"get_a_string_A14_for_2.23.87.19_A12_and_others")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")