re = /[0-9]+(?:\.[0-9]+)+/
str = 'get_a_string_A14_for_1.23.87.19_A12_and_others
get_a_string_A14_for_1.23.827.19_A12_and_others
get_a_string_A14_for_1.23.87.1_A12_and_others
get_a_string_A14_for_2.23.87.19_A12_and_others'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end