// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[0-9]+(?:\.[0-9]+)+").unwrap();
let string = "get_a_string_A14_for_1.23.87.19_A12_and_others
get_a_string_A14_for_1.23.827.19_A12_and_others
get_a_string_A14_for_1.23.87.1_A12_and_others
get_a_string_A14_for_2.23.87.19_A12_and_others";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}