import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]+(?:\\.[0-9]+)+";
final String string = "get_a_string_A14_for_1.23.87.19_A12_and_others\n"
+ "get_a_string_A14_for_1.23.827.19_A12_and_others\n"
+ "get_a_string_A14_for_1.23.87.1_A12_and_others\n"
+ "get_a_string_A14_for_2.23.87.19_A12_and_others";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}