#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:<span>Autogas[^]*)(?=[^]*<span ng-bind)([0-9.]{4})"
Local $sString = "<div class="fuel-price-entry" ng-controller="SpritsortenController" ng-init="init('0,659')">" & @CRLF & _
" <div class="fuel-price-type"><span>Autogas</div>" & @CRLF & _
" <div class="price-box">" & @CRLF & _
" <div class="price-input" ng-class="{'price-dirty': dirty}">" & @CRLF & _
" <span ng-click="minus()" class="decrease-price">-</span><span class="price-field"><span ng-bind="display_preis">0.65 </span> <sup ng-bind="suffix">9</sup></span><span ng-click="plus()" class="increase-price">+</span>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")