# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<span>Autogas[^]*)(?=[^]*<span ng-bind)([0-9.]{4})"
test_str = ("<div class=\"fuel-price-entry\" ng-controller=\"SpritsortenController\" ng-init=\"init('0,659')\">\n"
" <div class=\"fuel-price-type\"><span>Autogas</div>\n"
" <div class=\"price-box\">\n"
" <div class=\"price-input\" ng-class=\"{'price-dirty': dirty}\">\n"
" <span ng-click=\"minus()\" class=\"decrease-price\">-</span><span class=\"price-field\"><span ng-bind=\"display_preis\">0.65 </span> <sup ng-bind=\"suffix\">9</sup></span><span ng-click=\"plus()\" class=\"increase-price\">+</span>\n"
" </div>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.