import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<span>Autogas[^]*)(?=[^]*<span ng-bind)([0-9.]{4})";
final String string = "<div class=\"fuel-price-entry\" ng-controller=\"SpritsortenController\" ng-init=\"init('0,659')\">\n"
+ " <div class=\"fuel-price-type\"><span>Autogas</div>\n"
+ " <div class=\"price-box\">\n"
+ " <div class=\"price-input\" ng-class=\"{'price-dirty': dirty}\">\n"
+ " <span ng-click=\"minus()\" class=\"decrease-price\">-</span><span class=\"price-field\"><span ng-bind=\"display_preis\">0.65 </span> <sup ng-bind=\"suffix\">9</sup></span><span ng-click=\"plus()\" class=\"increase-price\">+</span>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}