import Foundation
let pattern = #"(?:<span>Autogas[^]*)(?=[^]*<span ng-bind)([0-9.]{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<div class="fuel-price-entry" ng-controller="SpritsortenController" ng-init="init('0,659')">
<div class="fuel-price-type"><span>Autogas</div>
<div class="price-box">
<div class="price-input" ng-class="{'price-dirty': dirty}">
<span ng-click="minus()" class="decrease-price">-</span><span class="price-field"><span ng-bind="display_preis">0.65 </span> <sup ng-bind="suffix">9</sup></span><span ng-click="plus()" class="increase-price">+</span>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)