const regex = /(?:<span>Autogas[^]*)(?=[^]*<span ng-bind)([0-9.]{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:<span>Autogas[^]*)(?=[^]*<span ng-bind)([0-9.]{4})', 'g')
const str = `<div class="fuel-price-entry" ng-controller="SpritsortenController" ng-init="init('0,659')">
<div class="fuel-price-type"><span>Autogas</div>
<div class="price-box">
<div class="price-input" ng-class="{'price-dirty': dirty}">
<span ng-click="minus()" class="decrease-price">-</span><span class="price-field"><span ng-bind="display_preis">0.65 </span> <sup ng-bind="suffix">9</sup></span><span ng-click="plus()" class="increase-price">+</span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}