re = /(?:<span>Autogas[^]*)(?=[^]*<span ng-bind)([0-9.]{4})/
str = '<div class="fuel-price-entry" ng-controller="SpritsortenController" ng-init="init(\'0,659\')">
<div class="fuel-price-type"><span>Autogas</div>
<div class="price-box">
<div class="price-input" ng-class="{\'price-dirty\': dirty}">
<span ng-click="minus()" class="decrease-price">-</span><span class="price-field"><span ng-bind="display_preis">0.65 </span> <sup ng-bind="suffix">9</sup></span><span ng-click="plus()" class="increase-price">+</span>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end