use strict;
my $str = '<div class="fuel-price-entry" ng-controller="SpritsortenController" ng-init="init(\'0,659\')">
<div class="fuel-price-type"><span>Autogas</div>
<div class="price-box">
<div class="price-input" ng-class="{\'price-dirty\': dirty}">
<span ng-click="minus()" class="decrease-price">-</span><span class="price-field"><span ng-bind="display_preis">0.65 </span> <sup ng-bind="suffix">9</sup></span><span ng-click="plus()" class="increase-price">+</span>
</div>';
my $regex = qr/(?:<span>Autogas[^]*)(?=[^]*<span ng-bind)([0-9.]{4})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}