#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\ ?){1,}[._\-\w]{1,25}\@[\-\w]{1,25}(\.[\-\w]{1,25}){1,3}?([\ ]{1,}?)?$"
Local $sString = " emanuel_on@catracalivre.com.br "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")