$re = '/^(\ ?){1,}[._\-\w]{1,25}\@[\-\w]{1,25}(\.[\-\w]{1,25}){1,3}?([\ ]{1,}?)?$/';
$str = ' emanuel_on@catracalivre.com.br ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);