package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\ ?){1,}[._\-\w]{1,25}\@[\-\w]{1,25}(\.[\-\w]{1,25}){1,3}?([\ ]{1,}?)?$`)
var str = ` emanuel_on@catracalivre.com.br `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}