const regex = /^(\ ?){1,}[._\-\w]{1,25}\@[\-\w]{1,25}(\.[\-\w]{1,25}){1,3}?([\ ]{1,}?)?$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\ ?){1,}[._\\-\\w]{1,25}\\@[\\-\\w]{1,25}(\\.[\\-\\w]{1,25}){1,3}?([\\ ]{1,}?)?$', '')
const str = ` emanuel_on@catracalivre.com.br `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}