# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\" )(?:[\w])/xxx/g;t' <<< "toto hector \" Don't do that\" \" hello I am a boy\" "