import Foundation
let pattern = #"(\" )(?:[\w])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"toto hector " Don't do that" " hello I am a boy" "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"xxx"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)